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Working with Vector Graphics 
In 5D™ Design Creator Software 
By Janie Lantz, Software Education Specialist 
 

 
5D™ Design Creator Software offers two methods for working with 
graphic fi les when creating an embroidery design.  The first 
method incorporates the Paint window, which produces Raster 
graphics that are formed from pixels.  The second method works 
with vector graphics in the Draw window.  Vector graphics consist 
of lines calculated mathematically from points, called nodes, 
rather than being composed of pixels.  As you change the size of 
a vector graphic, the lines are mathematically recalculated 
between the nodes, making vector graphics produce a much 
cleaner image that may be changed without losing quality. 

 
Reset All Modules 
1. Open 5D™ Embroidery .  

2. QuickLink to 5D™ Configure . 
3. Click on Reset All Modules.  
4. Click OK to the message, ‘All modules will be closed and reset to their default 

settings’. 
5. When you see the message, ‘Please confirm that all modules except 5D™ 

Configure are now closed’, ensure no other modules are open in the background.  
If they are, click on the module(s) in the background, and close after saving any work 
that might be in progress.  Click OK to the ‘All modules will be closed’ message 
when you have verified all other modules are closed. 

6. Click OK to the message, ‘All modules are now reset to their default settings’.   
Resetting the Modules will make all menus appear as they first installed, will reset all 
browse windows to their default size and folder, and will make the Control panels 
and toolbars reset to default.  No changes will be made in custom settings such as 
MyThreads, MyMachines, or MyHoops. 

7. Click OK to close 5D™ Configure.  
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QuickLink to 5D™ Design Creator Software 
1. Open the Desktop icon .  From the Program Folder, 

open 5D™ Embroidery . 
2. In the QuickLink Toolbar, select the 5D™ Design 

Creator icon . 
3. In the ExpressDesign Wizard – Choose Design Type, 

take a moment to review the options for creating Design 
Type. 

4. Click Help in the lower right corner of the ExpressDesign Wizard.  Click and drag 
the scrollbar down to learn more about each option in the Wizard. 
Note:  The first three options all contain ‘Express’ as part of their title, and all 
recognize raster graphics (pixilated).  The fourth option, Load a Picture in the Paint 
Window, and the sixth, Load a Background Picture into the Draw Window, also 
recognize raster graphics. 
The only Wizard options that recognize vector graphics (lines calculated 
mathematically from control points, called Nodes) are Load a Vector Graphic as 
Objects into the Draw Window, and Start a New Design with No Graphic (when you 
choose Draw Window in the Select Background Type step of the Wizard). 

 
Exploring Vector Graphic Properties 
5. Select Load a Vector Picture 

as Objects into the Draw 
Window.   
Notice how the ‘i’ for 
Information changes at the 
bottom of the selection menu. 

6. Click Next. 
7. In ExpressDesign Wizard – 

Choose Picture, click View 
Picture . 

8. Click the ellipsis  and browse to \my documents \5Dembroidery \samples 
\dcreate \pics2.   

9. Click OK to view the Thumbnails. 
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10. Click Page Down  or Page Up  to scroll through the graphics stored in the 
folder.   

11. Place the cursor over any thumbnail graphic and the name will pop up.  Notice these 
files are .4qb, a vector graphic image type. 

12. Click Page Up  to go to the top menu, and click the last thumbnail at bottom 
right, Teddy.4qb.  The image will load automatically into the viewer, and you can 
click Next. 

13. In ExpressDesign Wizard – Design Size, you may either specify the Hoop Size or the 
desired Design Size by either Height or Width. 

14. Select Fit Design to Hoop. 

15. Click Change Hoop . 
16. Change the Hoop Group to PFAFF® creative sensation™.  

Change the Hoop Size to the 120mm x 120mm – creative™ 120 
Square Hoop.  Make Orientation Vertical, and then click OK. 

17. Click Finish. 
 
The Filmstrip, Groups and Paths  
18. The image is loaded into the Draw tab, with the Filmstrip on the left, and the Draw 

Window Control Panel on the right. 
19. The Filmstrip shows a Root and a Group Insert with a + left of the words. 
20. Click the + sign, and the Group Insert will open. 
21. Within the Group Insert, three Paths and another Group are shown, stepped in to 

show they are sub-components of the Group Insert. 
Tip:  A Vector Graphic will always load into the Draw Window as a Group Insert, 
signifying the artwork was inserted initially as a grouped element.   

You can click on a Group Insert in the Filmstrip, and then click Ungroup  in the 
Group Tools from the Control Panel, to separate the Group Insert into its component 
parts.  The Group Insert will then disappear, as the parts are no longer grouped as 
they were when inserted! 

If the separate parts are re-selected, and Grouped , they will then appear as 
‘Group’ immediately under the Root, but no longer appear as Group Insert. 

You must click Undo  several times, if you want to go back to the point where you 
first inserted the artwork with the Wizard, showing Group Insert in the Filmstrip. 

22. If necessary, click the + sign beside Group Insert to open the group and view the 
component parts again. 
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23. In the Select tools in the Control Panel, click Box Select  to ensure it is 
highlighted (engaged). 

24. Click the first Path in the Filmstrip, the teddy bear body.  Notice the yellow body is 
surrounded by a select box within the work area. 

25. Click and drag the select box to the side, and only the body will move.  Notice the 
body is a complete ‘layer’ of color and outline. 
When vector graphics that contain layers are loaded into the Draw tab in 5D™ Design 
Creator, all existing layers of color are maintained.  If we create stitches in the body 
area of the bear, the entire area will be filled, and no ‘holes’ will be created under 
subsequent layers we might create, such as the muzzle or belly. 
If you wanted to create the body in a fur-like pattern texture, and then create an 
overlay of Wave Fill or Motif Fill in the muzzle and belly, working with layers could be 
very useful. 

26. Click Undo  once to move the body back into place. 

 
Combining Paths 
27. Hold down the CTRL key on the keyboard.  In the Filmstrip, click the second Path, 

the bear’s belly.  Both the body and the belly will be surrounded by boxes. 
28. Click Combine Paths  from the Edit tools in the Control Panel. 
29. The smaller element will create a void in the larger element, the bear’s body, and the 

smaller element will disappear. 
30. Now, we could create a body fi ll with no stitches under the belly area, except we 

have no image in the belly area over which to create a fi ll!  
31. Click Undo . 
32. Click outside all the objects to deselect them. 
33. Click the second Path, the belly, to select with a box. 
34. Hold down the CTRL key, and click the third path, the muzzle.   

35. Click Copy  to place both selected elements on the Clipboard viewer in the 
Control Panel. 
Tip:  Because you copied both elements at the same time, they will paste in as a 
‘Group’. 

36. Hold down the CTRL key.  Click the first Path, the bear’s body, in the Filmstrip.  All 
three Paths will be surrounded by individual select boxes. 

37. Click Combine Paths  in the Edit tools in the Control Panel. 
38. The bear’s body now has voids the size and shape of the muzzle and belly areas. 
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39. Click Paste  in the DrawEdit toolbar at the top of the Work Area.  
The muzzle and belly will be pasted back into the work area, and will 
still be surrounded by select boxes.  

40. To move the selected areas into place over the voids in the bear’s 
body, click and drag within one of the select boxes (when the ‘move’ 

 cursor is visible).  Alternatively, you may ‘nudge’ the selected 
objects using the keyboard arrow keys. 

 
Changing Order of Objects in the Filmstrip 
41. View the Filmstrip sequence.  The objects are layered so the top element comes first 

in the design.  To make the muzzle’s details visible, they need to be last in the 
Filmstrip.   

42. Click the Group with the facial features in the Filmstrip to select 
with a box.  At the bottom of the Filmstrip, click Move Forwards .  
The Group should move down in the list.   
However, because it is part of the original Group Insert, it is as far 
toward the bottom as it can go.  The next group down is a separate 
entity, as shown by the stepped sections in the Filmstrip. 

43. Click the Group Insert in the Filmstrip, near the top.   

44. Click Ungroup  in the Group toolbar in the Control Panel. 

45. Click Box Select . 
46. Click the Group of facial features in the Filmstrip. 

47. Click Move Forwards .  The Group will now move down a step in the Filmstrip. 

Alternatively, you could have selected Move to Front  to place the selected object 
at the end of the Filmstrip, the ‘last’ object in the layers, which means it’s now on top 
of all the other objects! 

48. Click Select All  in the Select toolbar in the Control Panel. 

 
Group and Change the Image Size 
49. Click Group . 
50. You now have one select box in the work area around the 

entire Group. 
51. Place the cursor over one of the square select handles 

on the corner of the select box. 
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52. Click and drag to make the bear slightly smaller. 

53. Click Center in Hoop  in the DrawDesign toolbar at the top of the Work Area, and 
the bear’s image will be centered both Vertically and Horizontally. 

 
Edit Design Shaping with Nodes 
54. Click the Group’s + sign if necessary (under the Root) in the Filmstrip to open all the 

objects in the Filmstrip.  Even though the objects are grouped, all the individual 
elements are available within the Group. 

55. Click the Path for the bear’s body. 

56. In the Edit Toolbar in the Control Panel, click Edit Nodes .   
Nodes are control points that define the angle or curvature of the connecting lines.  A 
round node specifies a curving line.  A square node (created by holding the CTRL 
key down while you click or move a node) makes an angle or straight line segment. 

57. Click the + on the Zoom slider at bottom right until you are zoomed to about 100%.   
58. Click the Overview window in the Control Panel. 
59. Click and drag the zoom indicator box until the right arm is 

centered in the Work Area. 
60. Click and drag a node on the outer arm to shape an elbow on 

the arm.  
61. Zoom very closely on the area where the arm meets the body 

on the lower side.  Several nodes are grouped almost on top of 
each other, because the darker outline has an angular jog near the end of the ‘v’. 

62. Select Delete Nodes  from the Edit tab in the Control Panel.  Click on any nodes 
you’d like to remove. 

63. Click Edit Nodes  again, and hold down the CTRL key on 
the keyboard.  Click to select and then release on the node 
remaining on the end of the ‘v’.  When you release the node, 
you will have a square point, and a sharp corner. 

64. Click Zoom to Fit . 

65. Continue to Edit Nodes  as desired, to reshape the bear. 
Tip:  You can click and move nodes to reshape the lines of any selected object in the 
Filmstrip. 
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Change Object Properties 
66. Click Box Select  in the Select tools in the Control Panel. 
67. Click the Path for the bear’s body in the Filmstrip.   
68. Hold down the CTRL key.  Click on the Paths for the muzzle and for the belly.  All 

three Paths will be surrounded by select boxes. 
69. Hover over the select boxes in the Work Area and right click to open the Object 

Properties. 
70. Left click on the dark brown color.  This will change the lines in all three objects to 

dark brown. 
71. Click OK to Object Properties. 
72. Click on the Path with the bear’s body. 
73. Right click over the select box in the Work Area. 
74. In Object Properties, right click on the light brown to change the fill color of the 

bear’s body. 
75. Click OK to Object Properties. 

 
Save Image Files 
76. Click Save As Drawing , and save in Documents \5DEmbroidery \MyPictures.  

Name the picture MyTeddy.  Note the Save As Type is .4QB.  Click Save. 
77. Select File in the Menu Bar at the top of the Work Area.  Select Export as Clip Art.   

Note there is no icon for this command. 
78. Click the drop-down menu in Save As Type, and select the file format of your 

choice.  Name the file MyTeddy.  Click Save. 

79. Click Send to Wizard  from the DrawMain toolbar.  Click No to the prompt to save 
the Teddy again. 

 
Send To Wizard from the Draw Tab 
80. Send to Wizard has two options.   
81. The first, Merge All Layers (flatten) will automatically make the artwork one single 

layer, and will determine the optimal order to stitch the design elements, producing a 
.can file with stitch objects. 

82. The second, Retain individual object layers, wi ll create the areas of stitches 
exactly as you created them, and the same order as they appear in the Filmstrip. 
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Tip:  With the second option, if we had not created voids in the bear’s body fi ll, we 
could have made a solid body area with open overlay objects of the muzzle and 
belly! 

83. Select Retain individual object layers.  Click 
OK. 

84. The Wizard will finish, and produce a finished 
.can file. 

85. Click the Edit tab.  Review the elements used to create the .can file.  Note the larger 
objects with a fill color were created as fill areas with borders, simplifying the number 
of objects in the .can file. 

86. Click New .  If prompted to save the .can file, click No. 
87. In the ExpressDesign Wizard – Choose Design Type, select Load a Vector Picture 

as Objects into the Draw Window.  Click Next. 

88. Click View Picture . 
89. Browse to Documents \MyPictures.  Select MyTeddy.4QB.  Click Next.  Leave all 

settings the same in ExpressDesign Wizard – Design Size.  Click Finish. 

90. Select Send to Wizard .  Choose Merge All Layers (flatten). 
91. In ExpressDesign Wizard – Choose Design Type, choose Create 

Express Embroidery.  Click Next. 
92. In ExpressDesign Wizard – Reduce Colors, leave everything as it is.  

Click Next. 
93. In ExpressDesign Wizard – Choose Thread Colors, place a check 

beside Automatically Remove Background Colors.  Leave Remove 
Background Color Only selected.  Click Next. 

94. In ExpressDesign Wizard – Fabric and Stitch Type Options, uncheck 
Design Underlay.  Click Finish. 

95. Select the Edit tab.  Scroll through the Filmstrip and review the number 
of elements used to create the embroidery design. Note the outlines 
were traced by themselves, and appear as multiple segments of stitches 
in the .can file.  

  
Vector graphics in the Draw tab offer multiple other options as well.  Browse the 5D™ 
Design Creator Help files for more techniques and information! 
 


